어느순간부터 yum 실행 시 KeyboardInterrupt 에러가 발생합니다.
조회수 2163 답변수 1 반응수 1 등록일 2016.10.10 23:48:51


  1. File "/usr/bin/yum", line 30
  2.    except KeyboardInterrupt, e:

python 버전을 2.6.6 에서 3.5.2로 업그레이드 한 후부터 yum 을 실행 시 KeyboardInterrupt 에러가 발생합니다.

OS : CentOS release 6.7 (Final)


말씀하신대로 파이썬 버전으로 인해 발생하는 에러로

yum 을 기존 파이썬 2.6.6 을 바라보도록 수정하시면 됩니다.


  1. #/usr/bin/yum
  2. !/usr/bin/python2
  3. import sys
  4. try:
  5.     import yum
  6. except ImportError:
  7.     print >> sys.stderr, """\
  8. There was a problem importing one of the Python modules
  9. required to run yum. The error leading to this problem was:
  10. ...


위 /usr/bin/python 코드를 수정해보세요


2016.10.12 00:19:20 반응 이력

답변 작성

질문에 적합한 답변을 상세히 작성해 주시기 바랍니다.

답변이 찬성되면 태그평판 +2점이 적립, 반대되면 태그평판 -1점 차감됩니다.

답변이 채택되면 태그평판 +10점이 적립됩니다.