This query requires pytz, but it isn't installed
조회수 2455 답변수 1 반응수 1 등록일 2016.08.03 00:25:00

안녕하세요 현재 django 1.9.7 버전과 python 3.5.1 버전으로 페이지 제작중에 

아래와 같이 에러 메세지가 출력되었습니다.

  1. ImproperlyConfigured at /admin/archive/
  2. This query requires pytz, but it isn't installed.
  3. Request Method:     GET
  4. Request URL:     http://127.0.0.1:8000/admin/archive
  5. Django Version:     1.9.7
  6. Exception Type:     ImproperlyConfigured
  7. Exception Value:    
  8. This query requires pytz, but it isn't installed.
  9. Exception Location:     /Users/AB/source/Python/pyDjango/boot/lib/python3.5/site-packages/django/db/backends/sqlite3/operations.py in _require_pytz, line 75
  10. Python Executable:     /Users/AB/source/Python/pyDjango/boot/bin/python
  11. Python Version:     3.5.1


  1. pip install pytz

그래서 위와 같이 pip 를 이용하여 pytz를 설치하였지만 해결되지 않고 동일한 에러메세지를 출력하고 있습니다.


혹시 설치 후에 웹서버에 대한 재시작을 하셨나요?

재시작을 해야 pytz가 적용되지만 질문 내용중에 재시작에 대한 내용은 빠져있어서요

확인 부탁드릴게요~

2016.08.03 23:42:14 반응 이력
테스트 웹서버로 runserver를 쓰고 있는데 재시작을하니 잘되네요 감사합니다 막내 2016.08.04 23:46:57

답변 작성

질문에 적합한 답변을 상세히 작성해 주시기 바랍니다.

답변이 찬성되면 태그평판 +2점이 적립, 반대되면 태그평판 -1점 차감됩니다.

답변이 채택되면 태그평판 +10점이 적립됩니다.